omelement trouble with axis2 versions

Tue, Mar 6, 2007

With all the tinkering I’ve been doing with Axis2 and only using trunk builds as I need my xsdconfig support, I get this error now and again when a client is calling a service:

AxisFault: “ServiceClass does not implement required method of the form OMElement”

The problem is the client and service are built using Axis2 trunk but the actual web application in which Axis2 is embedded is running Axis2 1.1.1

Upgrading the web application to Axis2 trunk sorts it. Hopefully this error will disappear once the next version of Axis2 comes out, with my xsdconfig patch.

comments powered by Disqus