getting a new iphone ready for development

Fri, Nov 25, 2011

It’s not quite enough to just plug in your new iPhone, open XCode’s Organizer and bung your updated provisioning profile into it. You’ll see this error instead when you try to deploy to the device:

XCode cannot run using the selected device

No provisioned iOS devices are available with a compatible iOS version. Connect an iOS device with a recent enough version of iOS to run your application or choose an iOS simulator as the destination.

You need to go into Organizer and select your new iPhone from the list of devices on the left and click the big Use for development button and it’ll download info from the phone. You’ll prolly then get the error:
No iOS Distribution Certificate found
Let XCode submit a request on your behalf and then login to your iOS developer account at Apple and you’ll see theĀ iOS Team Provisioning Profile which is managed by XCode. Once that’s down you don’t need to download anything else. Just choose your phone’s name from the build targets and off you go.

comments powered by Disqus